Degraded builds and deploys in Virginia

Incident Report for Render

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 17:59 UTC

Identified

An upstream provider is experiencing issues provisioning infrastructure. We continue to monitor the situation.

Paid services are experiencing less delay than free services.
Posted Oct 28, 2025 - 17:34 UTC

Investigating

Builds and deploys may be slower than usual. We are currently investigating this issue.
Posted Oct 28, 2025 - 17:08 UTC
This incident affected: Virginia (Builds and Deploys).