Platform latency

Incident Report for Render

Resolved

This incident has been resolved.
Posted Jun 11, 2026 - 14:57 UTC

Monitoring

A fix has been implemented, and we are continuing to monitor.

Auto-deploys would have been affected/missed by these delays and will need to be retriggered.
Posted Jun 11, 2026 - 14:56 UTC

Investigating

We are currently investigating delays across the platform affecting builds, deploys, and webhooks.
Posted Jun 11, 2026 - 14:37 UTC
This incident affected: Oregon (Builds and Deploys), Frankfurt (Builds and Deploys), Singapore (Builds and Deploys), Ohio (Builds and Deploys), and Virginia (Builds and Deploys).