Certificate issue with Render dashboard
Incident Report for Render
Resolved
Users should now be able to access dashboard.render.com.
Posted Aug 30, 2020 - 23:12 UTC
Investigating
We are updating the certificate for Render's dashboard.
Posted Aug 30, 2020 - 21:16 UTC
This incident affected: Render Dashboard.