Pre-deploys are failing in some regions

Incident Report for Render

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 18:15 UTC

Monitoring

A fix has been rolled out, and a re-deploy should now work as expected. We’re still keeping an eye on how the fix performs though.
Posted Oct 23, 2025 - 17:22 UTC

Identified

We’ve found the root cause and are rolling out a fix.
Posted Oct 23, 2025 - 16:56 UTC

Update

Some pre-deploys in Singapore are also affected.
Posted Oct 23, 2025 - 16:47 UTC

Update

We think some pre-deploys are failing in Oregon and Frankfurt. We haven’t found any other affected regions so far, but we’re actively checking.
Posted Oct 23, 2025 - 16:29 UTC

Investigating

We are currently investigating this issue.
Posted Oct 23, 2025 - 16:27 UTC
This incident affected: Oregon (Web Services) and Frankfurt (Builds and Deploys).