HA Postgres Unavailability

Incident Report for Render

Resolved

Everything is back to normal, and the incident is now resolved. We are planning long-term mitigations to prevent this issue from recurring, and we will share the results of our investigation with all affected customers.
Posted May 07, 2026 - 02:54 UTC

Update

All affected instances are back online, though a few databases may still show a stale 'Unready' status. We are working to refresh the status.
Posted May 07, 2026 - 02:47 UTC

Update

We're continuing to see instance recovery across the fleet. Render Workflows is now fully operational.
Posted May 07, 2026 - 02:38 UTC

Update

We're bringing the affected Postgres instances back online and expect full recovery within fifteen minutes.
Posted May 07, 2026 - 02:34 UTC

Identified

We've identified the issue and are implementing a fix.
Posted May 07, 2026 - 02:21 UTC

Update

We are continuing to investigate this issue.
Posted May 07, 2026 - 02:07 UTC

Update

We are continuing to investigate this issue.
Posted May 07, 2026 - 02:01 UTC

Investigating

We're investigating reports of Postgres unavailability in multiple regions. At this point we believe this only impacts databases with HA turned on.
Posted May 07, 2026 - 02:00 UTC
This incident affected: Oregon (PostgreSQL, Workflows), Frankfurt (PostgreSQL, Workflows), Ohio (PostgreSQL, Workflows), Singapore (PostgreSQL, Workflows), and Virginia (PostgreSQL, Workflows).