Dashboard and Redis not responsive, builds and deploys are delayed

Incident Report for Render

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 19:50 UTC

Update

Dashboard is mostly recovered, but Shell access is still impacted.

Redis/KeyVal was also impacted, but is now recovered.
Posted Mar 27, 2025 - 18:26 UTC

Update

Builds and deploys are now fully operational.
Posted Mar 27, 2025 - 18:11 UTC

Identified

We have identified the issue and are working on resolution.
Posted Mar 27, 2025 - 18:00 UTC

Monitoring

We've identified an issue that caused Dashboard to be non-responsive for ~10 minutes (between 17:19 and 17:30 UTC). A fix has been put in place and we are monitoring results.
Posted Mar 27, 2025 - 17:37 UTC
This incident affected: Render Dashboard, Oregon (Builds and Deploys, Redis), Singapore (Builds and Deploys, Redis), Ohio (Builds and Deploys, Redis), and Virginia (Builds and Deploys, Redis).