Intermittent service restarts
Incident Report for Render
Resolved
Changes have been made to mitigate resource overruns, avoiding service restarts. While it is possible that resource overuse can always occur in any application execution environment, these changes mitigated the elevated level of failures that led us to open the incident.
Posted Jul 31, 2024 - 19:33 UTC
Identified
A fix has been identified and is being rolled out across the platform.
Posted Jul 25, 2024 - 03:26 UTC
Investigating
Some services are experiencing intermittent restarts at elevated rates due to sporadic failures of underlying resources. While stateless services without an attached disk typically recover quickly, stateful services take longer to fully restart due to the need to guarantee data integrity during this process. Engineering is investigating the cause of the elevated rate of failure of underlying resources.
Posted Jul 23, 2024 - 23:16 UTC
This incident affected: Oregon (Web Services, Cron Jobs, Background Workers, PostgreSQL, Redis), Frankfurt (Web Services, Cron Jobs, Background Workers, PostgreSQL, Redis), Ohio (Web Services, Cron Jobs, Background Workers, PostgreSQL, Redis), Singapore (Web Services, Cron Jobs, Background Workers, PostgreSQL, Redis), and Virginia (Web Services, Cron Jobs, Background Workers, PostgreSQL, Redis).