We've implemented a fix and are monitoring the results. Deploy failure reasons will be temporarily unavailable. Deploy failure events will still be generated. We will provide an update once deploy failure reasons are re-enabled.
Posted Jul 27, 2026 - 20:18 UTC
Update
The REST API is also experiencing degraded performance. As a result, requests to it may experience timeouts and you may need to retry your request.
We are continuing to investigate.
Posted Jul 27, 2026 - 18:27 UTC
Update
We are continuing to investigate this issue.
Posted Jul 27, 2026 - 17:59 UTC
Update
We are continuing to investigate this issue.
Posted Jul 27, 2026 - 16:20 UTC
Investigating
Requests through the dashboard may be slower than usual. We're currently investigating the issue.
Posted Jul 27, 2026 - 14:43 UTC
This incident affects: Render Dashboard and Render REST API.