Degraded performance for some users in Oregon

Incident Report for Render

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 22:19 UTC

Update

Render is fully recovered, but we're still monitoring ongoing recoveries with upstream providers. Please do reach out to us if you're still seeing anything unusual.
Posted Jun 12, 2025 - 21:08 UTC

Monitoring

Upstream providers are beginning to recover, but we will continue to monitor the impact to Render until we see a full recovery.
Posted Jun 12, 2025 - 19:40 UTC

Update

We've learned that several upstream providers are showing performance degradation, which may impact builds and deploys to Render users.
Posted Jun 12, 2025 - 19:16 UTC

Update

We are coordinating with an upstream provider to investigate the source of a performance degradation. This is impacting some users with static sites in Oregon.
Posted Jun 12, 2025 - 18:38 UTC

Investigating

Engineers have been alerted to and are investigating an issue causing performance degradation for some users in Oregon.
Posted Jun 12, 2025 - 18:25 UTC
This incident affected: Oregon (Web Services, Web Services - Free Tier) and Static Sites.