We are continuing to work on a fix for this issue.
In the meantime, stuck deploys can be cleared with these steps: * Go into Workspace Settings * Change the Overlapping Deploy Policy to "Override" * Initiate a new deploy (which will then cancel the stuck deploy) * Change the Deploy Policy back to "Wait"
Posted Jun 11, 2026 - 16:44 UTC
Identified
The earlier "Platform latency" incident has affected queued deploys. We are implementing a fix
Posted Jun 11, 2026 - 16:01 UTC
This incident affected: Oregon (Builds and Deploys), Frankfurt (Builds and Deploys), Singapore (Builds and Deploys), Ohio (Builds and Deploys), and Virginia (Builds and Deploys).