GitHub outage affecting new service creation and service deploys

Incident Report for Render

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 00:14 UTC

Monitoring

GitHub reports that they have mitigated their incident and are monitoring to ensure stability.
Posted Jul 17, 2026 - 00:13 UTC

Identified

GitHub has updated its status page to report degraded REST API availability: https://www.githubstatus.com/incidents/gxycch3076xk
Posted Jul 16, 2026 - 23:09 UTC

Update

We are continuing to investigate this issue.
Posted Jul 16, 2026 - 22:42 UTC

Investigating

We are currently investigating this issue.
Posted Jul 16, 2026 - 22:42 UTC
This incident affected: Oregon (Builds and Deploys), Frankfurt (Builds and Deploys), Singapore (Builds and Deploys), Ohio (Builds and Deploys), and Virginia (Builds and Deploys).