Slow dashboard performance
Incident Report for Render
Resolved
This incident has been resolved.
Posted Nov 08, 2022 - 18:29 UTC
Monitoring
We have applied a fix and are seeing signs of recovery. We are currently monitoring.
Posted Nov 08, 2022 - 18:15 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 08, 2022 - 17:51 UTC
Identified
We are aware issues causing of slow dashboard performance. We have identified the cause and are currently taking steps to remediate it.
Posted Nov 08, 2022 - 17:50 UTC
This incident affected: Render Dashboard.