Some Datadog metrics are missing for Postgres databases
Incident Report for Render
Resolved
The missing metrics will start to work again after the next maintenance cycle. If you would like this sooner, please reach out to support@render.com.
Posted Aug 24, 2023 - 22:32 UTC
Monitoring
A fix has been implemented; however, it requires a database restart to enable the six metrics again. Please reach out to support@render.com if you would like it to be enabled; otherwise, the metrics will be available again after the next maintenance period.
Posted Aug 18, 2023 - 20:41 UTC
Investigating
The "system.*" metrics are missing for some users using the Postgres Datadog integration. The rest of the metrics are still functional, and there is no impact on the uptime of the database itself.

See https://render.com/docs/datadog#available-metrics for a complete list of metrics Render provides.

Render engineers are investigating the root cause of the issue.
Posted Aug 17, 2023 - 16:26 UTC
This incident affected: Oregon (PostgreSQL), Frankfurt (PostgreSQL), Ohio (PostgreSQL), and Singapore (PostgreSQL).