Render Maintenance Period

Incident Report for Render

Resolved

This maintenance has been canceled. We were able to workaround the need for a maintenance period.
Posted Mar 17, 2025 - 23:30 UTC

Investigating

We will be upgrading critical infrastructure on March 19th at 4:00 pm PDT (March 19th 11:00 pm UTC). For up to 30 minutes, you will be unable to view, edit, create or deploy services and databases.

There will be no interruptions to deployed services and databases.

If you need help, please get in touch at support@render.com or talk to us on our community forum, https://community.render.com
Posted Mar 12, 2025 - 20:50 UTC
This incident affected: Render Dashboard and Render API.