Delayed wildcard issuance or renewal

Incident Report for Render

Resolved

Issuance has returned to expected performance and we've observed no further impact.
Posted Jul 02, 2026 - 19:59 UTC

Identified

Due to an ongoing LetsEncrypt incident, wildcard certificates may be slow to issue/renew. We are actively monitoring the situation.
Posted Jul 02, 2026 - 19:09 UTC
This incident affected: Custom Domains.