Service instability in Singapore

Incident Report for Render

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 18:09 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 31, 2026 - 17:22 UTC

Update

Inbound traffic to Singapore services is impacted.

Free service spin-ups (from idle) in Singapore have been temporarily disabled while we continue to investigate.
Posted Aug 31, 2026 - 16:33 UTC

Update

We've observed that deploys are primarily affected by this.
Posted Aug 31, 2026 - 16:08 UTC

Investigating

We are investigating service instability affecting some web services in our Singapore region. Customers may experience unexpected service restarts or intermittent availability.

Our team is actively investigating and working to restore normal operation. We will provide an update as more information becomes available.
Posted Aug 31, 2026 - 15:47 UTC
This incident affected: Singapore (Web Services, Builds and Deploys).