Performance has returned to expected levels, we are monitoring for any further issues.
Posted Aug 13, 2025 - 23:48 UTC
Identified
We have been alerted to performance issues causing delayed deployments for Oregon hosted services. Deploys are taking an increased amount of time to complete. We have begun steps toward remediating this issue.
Posted Aug 13, 2025 - 23:08 UTC
This incident affected: Oregon (Builds and Deploys).