New service creation failing without a card on file
Incident Report for Render
Resolved
The issue is fixed. Sorry for the trouble and thank you for your patience!
Posted Jan 07, 2020 - 19:39 UTC
Monitoring
We've deployed a fix and are continuing to monitor the dashboard.
Posted Jan 07, 2020 - 19:29 UTC
Identified
We've identified the issue and are deploying a fix soon.
Posted Jan 07, 2020 - 18:02 UTC
Investigating
New service creation via the dashboard is failing for some users without a card on file.
Posted Jan 07, 2020 - 17:49 UTC
This incident affected: Render Dashboard.