Services using the latest Node 18 release fail to deploy
Incident Report for Render
Resolved
In order to prevent further failures, engineering has temporarily published Node 18.20.5 using 18.20.4's resources for Render-hosted services. This will be undone as soon as 18.20.5 is normally available.
This issue has been resolved.
Posted Nov 13, 2024 - 00:28 UTC
Update
Node v18.20.5 was released a bit over an hour ago, but its download directories do not contain the necessary data. Services using Node that specify this version, typically by specifying use of the latest release in the v18 series, will fail to deploy, or in the case of Cron Jobs, fail to execute even without a new deployment.
Engineering is investigating alternatives to prevent services from failing in this manner.
Posted Nov 12, 2024 - 23:43 UTC
Identified
Cron Job execution logs indicate the environment being set up, but the cron job's command is never executed. Engineering is actively investigating.
Posted Nov 12, 2024 - 22:51 UTC
This incident affected: Oregon (Cron Jobs, Builds and Deploys), Frankfurt (Cron Jobs, Builds and Deploys), Ohio (Cron Jobs, Builds and Deploys), Singapore (Cron Jobs, Builds and Deploys), and Virginia (Cron Jobs, Builds and Deploys).