Slow/failing wildcard certificates related to LetsEncrypt incident

Incident Report for Render

Resolved

We have observed no further impact from the upstream LetsEncrypt issue over the last 4 hours. All Render systems are fully operational.
Posted Jun 19, 2026 - 00:17 UTC

Monitoring

We are no longer observing any impact from the LetsEncrypt incident. We continue to monitor.
Posted Jun 18, 2026 - 23:15 UTC

Identified

We are seeing slow or failing issuance of wildcard certificates due to an ongoing incident with the LetsEncrypt certificate authority. We are actively monitoring the situation on our end.
Posted Jun 18, 2026 - 21:06 UTC
This incident affected: Custom Domains.