Slow Dashboard
Incident Report for Render
Resolved
This incident has been resolved.
Posted Jun 27, 2024 - 03:32 UTC
Identified
We have identified the issue and mitigated it. We are now working on a permanent fix.
Posted Jun 27, 2024 - 02:52 UTC
Investigating
We’ve identified slow loading speeds in the dashboard and are investigating
Posted Jun 27, 2024 - 01:49 UTC
This incident affected: Render Dashboard.