Upstream provider outage causing delays provisioning custom domains

Incident Report for Render

Resolved

Our upstream provider has resolved the issue and custom domain provisioning has recovered.
Posted May 22, 2026 - 16:37 UTC

Monitoring

Our upstream provider has deployed a fix and we're seeing gradual recovery.
Posted May 22, 2026 - 16:25 UTC

Investigating

We are currently investigating this issue.
Posted May 22, 2026 - 15:53 UTC
This incident affected: Custom Domains.