Ongoing incident with Google Cloud Platform
Incident Report for Render
Resolved
This incident has been resolved.
Posted Sep 25, 2020 - 06:05 UTC
Update
Google Cloud's incident was resolved at 19:31 PT. We continued monitoring and believe that performance has been back to normal since then.
Posted Sep 25, 2020 - 03:50 UTC
Monitoring
Some services may be affected by the ongoing Google Cloud Platform incident.

Google Cloud Status Updates: https://status.cloud.google.com//incident/zall/20010
Posted Sep 25, 2020 - 01:42 UTC
This incident affected: Builds and Deploys.