Elevated deployment failures

Incident Report for Render

Resolved

This incident has been resolved.
Posted Oct 18, 2022 - 19:56 UTC

Update

We have deployed improvements to our DNS architecture across all regions. We will continue to monitor DNS performance.
Posted Oct 18, 2022 - 02:15 UTC

Update

We identified a problem that caused some deploys to fail to finish from 2022/10/17 5:31 PT to 5:40 PT. We have resolved the issue. Users should manually redeploy if their deploy is failing to finish.
Posted Oct 18, 2022 - 01:32 UTC

Update

We’ve deployed improved DNS infrastructure to one of our Oregon clusters which has further improved DNS performance.

We’re in the process of deploying the same improvements to all other services and will continue to monitor for impact.
Posted Oct 17, 2022 - 23:42 UTC

Update

We’ve observed a significant decrease in deploy failures due to GitHub DNS resolution errors. We are implementing additional mitigations for the remaining errors.
Posted Oct 12, 2022 - 23:09 UTC

Monitoring

We’ve implemented a fix and are monitoring the results. Please retry any failed deploys.
Posted Oct 11, 2022 - 21:42 UTC

Identified

We’ve identified the problem and are rolling out a fix.
Posted Oct 11, 2022 - 20:12 UTC

Investigating

We are investigating elevated deployment failures due to GitHub DNS resolution errors. Users may see the following error: "Could not resolve host: github.com".
Posted Oct 11, 2022 - 18:57 UTC