Dashboard is slow to load

Incident Report for Render

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 16:04 UTC

Monitoring

We’ve mitigated the issue, but we’re still keeping an eye on things to make sure the dashboard stays stable and to dig into what caused it.
Posted Jul 10, 2025 - 15:34 UTC

Investigating

We are currently investigating this issue.
Posted Jul 10, 2025 - 15:24 UTC
This incident affected: Render Dashboard and Render API.