Issues accessing the Render dashboard

Incident Report for Render

Resolved

This incident has been resolved.
Posted May 09, 2025 - 03:30 UTC

Monitoring

Our team has mitigated this issue and is monitoring the situation. The impact time for this incident is 2025-05-09 02:35 to 02:51 UTC. During this time the following will have been impacted:
- Dashboard
- REST API
- Builds
- Deployments
Posted May 09, 2025 - 03:03 UTC

Investigating

We are currently investigating issues accessing the Render dashboard. Our team is investigating. This should only be impacting access to the dashboard. Render services should not be impacted.
Posted May 09, 2025 - 02:54 UTC
This incident affected: Render Dashboard, Oregon (Builds and Deploys), Frankfurt (Builds and Deploys), Singapore (Builds and Deploys), Ohio (Builds and Deploys), and Virginia (Builds and Deploys).