Slow Dashboard

Incident Report for Render

Resolved

This incident has been resolved
Posted Apr 29, 2024 - 21:01 UTC

Monitoring

We've mitigated the issue and are monitoring dashboard loading speeds
Posted Apr 29, 2024 - 20:18 UTC

Investigating

We’ve identified slow loading speeds in the dashboard and are investigating
Posted Apr 29, 2024 - 19:45 UTC
This incident affected: Render Dashboard.