Engineers have applied a fix and dashboard and API performance have recovered.
Posted Jun 20, 2025 - 14:55 UTC
Identified
We’ve identified the issue and are working on a fix. The dashboard should still be mostly usable, but you might notice some slowdowns or brief periods where it hangs.
Posted Jun 20, 2025 - 14:24 UTC
Investigating
We are currently investigating this issue.
Posted Jun 20, 2025 - 13:23 UTC
This incident affected: Render Dashboard, Render API, and Render REST API.