Some services and datastores in Singapore experiencing brief disruptions

Incident Report for Render

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 18:44 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2026 - 18:18 UTC
This incident affected: Singapore (Web Services, Cron Jobs, Background Workers, PostgreSQL, Redis, Web Services - Free Tier).