Degraded builds and deployments in the Singapore region

Incident Report for Render

Resolved

We believe this incident has been successfully mitigated. If you continue to experience any issues, please contact support@render.com.
Posted Mar 13, 2026 - 11:09 UTC

Monitoring

We have re-enabled services using the free instance types in the Singapore region and are currently monitoring the impact.
Posted Mar 13, 2026 - 10:18 UTC

Update

We have disabled services using free instance types in the Singapore region
Posted Mar 13, 2026 - 09:27 UTC

Investigating

Builds and deployments in the Singapore region are currently experiencing degraded performance. You may notice longer than usual completion times.
Posted Mar 13, 2026 - 08:52 UTC
This incident affected: Singapore (Builds and Deploys, Web Services - Free Tier).