Deploy delays in Oregon

Incident Report for Render

Resolved

This incident has been resolved.
Posted Jan 08, 2026 - 18:48 UTC

Monitoring

We have implemented a fix and are monitoring for further issues.
Posted Jan 08, 2026 - 18:26 UTC

Investigating

Some users may experience slower build times for services deployed in Oregon.
Posted Jan 08, 2026 - 16:47 UTC
This incident affected: Oregon (Builds and Deploys).