Elevated Latency for Requests to Web Services and Static Sites in Frankfurt

Incident Report for Render

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 23:52 UTC

Monitoring

Latency has remained stable. We continue to monitor the situation.
Posted Dec 05, 2025 - 23:29 UTC

Update

Latency has normalized. We continue to investigate with our upstream vendor to identify the cause.
Posted Dec 05, 2025 - 23:19 UTC

Investigating

We are currently investigating this issue.
Posted Dec 05, 2025 - 23:03 UTC
This incident affected: Frankfurt (Web Services) and Static Sites.