Duplicate Maintenance Emails

Incident Report for Render

Resolved

We’re incredibly sorry for multiple emails going out to everyone. We’ve fixed the issue.
Posted Feb 08, 2022 - 21:50 UTC

Investigating

We are currently aware of an issue causing multiple maintenance emails to be sent out. We are investigating the issue.
Posted Feb 08, 2022 - 21:47 UTC