Incorrect IP allowlists configured for new Environments created via REST API

Incident Report for Render

Resolved

Changes were deployed to fix the issue with new Environments created via the REST API. All affected Environments have been updated to be their default Allow-All if not otherwise specified in the API call's parameters. This issue has been resolved.
Posted Oct 10, 2025 - 21:17 UTC

Identified

We have identified and are working to fix Environments recently created via the REST API to ensure default IP allowlists are configured correctly. Until then, new Services created in these Environments may be responding to requests with unexpected errors.
Posted Oct 10, 2025 - 19:34 UTC
This incident affected: Render REST API.