Slow or Erroring Dashboard and APIs

Incident Report for Render

Resolved

Normal Dashboard and REST API performance has resumed.
Posted Sep 06, 2024 - 19:56 UTC

Update

A change to the Render API system resulted in slow performance for our Dashboard and REST API. We have reverted this change and are monitoring performance, which appears to have returned to normal. Customer services hosted on Render should not have been affected by this incident unless they are also active users of our REST API.
Posted Sep 06, 2024 - 19:20 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 06, 2024 - 18:45 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 06, 2024 - 18:45 UTC

Identified

The Render Dashboard ( https://dashboard.render.com/ ) is encountering performance issues causing slow page loads, or timeouts and failures to load pages. Engineering is actively addressing the issue.

Customer services hosted on Render are not affected by this incident.
Posted Sep 06, 2024 - 18:26 UTC
This incident affected: Render Dashboard.