Issues with transactional emails from Render
Incident Report for Render
Resolved
This issue has been resolved. If you require a fresh email verification or password reset you can re-request them.
Posted Dec 17, 2022 - 16:07 UTC
Monitoring
The upstream provider is close to delivering the backlog. However, if you require a fresh email verification or password reset you can re-request them
Posted Dec 17, 2022 - 14:54 UTC
Update
Our upstream provider is recovering and we're seeing emails shown as delivered. They are continuing to work through delivering backlogged emails.
Posted Dec 17, 2022 - 10:50 UTC
Update
Our upstream email provider is working to speed up the backlog of queued messages. We’ll continue to post updates here as we receive them.
Posted Dec 16, 2022 - 23:46 UTC
Identified
An upstream email provider is experiencing delays in sending some of our transactional emails (email verification, password reset, etc.). We'll post updates as we have them.
Posted Dec 16, 2022 - 21:01 UTC