We understand the issue is resolved now. If you're still seeing issues, please reach out.
Posted Dec 02, 2025 - 16:00 UTC
Identified
The provider is actively working on the issue and we’re seeing some progress on certificate issuance. We’re still waiting on full confirmation that the fix is complete.
Posted Dec 02, 2025 - 15:30 UTC
Investigating
You may see certificates stuck on 'Pending' after adding a custom domain. We’ve located an issue with a provider and are looking into it right now.