Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 21, 2025 - 01:00 UTC
Scheduled
We will be upgrading critical infrastructure on Nov 20th at 5:00 PM PST (Nov 21st 1:00 AM UTC). The upgrade is expected to take up to 30 minutes. During this time, you will be unable to view, edit, create, or deploy any Render resources (including services, datastores, or one-off jobs). The Render Dashboard and REST API will be unavailable.
There will be no interruption to running services and datastores.
If you need help, please contact our support team at support@render.com.
Posted Nov 20, 2025 - 20:00 UTC
This scheduled maintenance affected: Render Dashboard, Render Platform API, Render REST API, and One-Off Jobs.