Certificate issuance paused for Let's Encrypt

Incident Report for Render

Resolved

Let's Encrypt has resumed certificate issuance.
Posted May 08, 2026 - 21:06 UTC

Monitoring

Due to an ongoing incident, Let's Encrypt has paused all certificate issuance. This primarily impacts wildcard domains on Render. In rare instances, non-wildcard custom domains may be using Let's Encrypt for their certificates.
Posted May 08, 2026 - 20:22 UTC
This incident affected: Custom Domains.