Web services (Oregon) and static sites availability disruption

Incident Report for Render

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 20:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.

Impact resulted in intermittent latency, timeouts, and errors for some services for ~6 minutes (11:46-11:52 PST).
Posted Nov 25, 2025 - 20:18 UTC

Investigating

We are currently investigating an issue impacting web service and static site availability.
Posted Nov 25, 2025 - 20:13 UTC
This incident affected: Oregon (Web Services, Web Services - Free Tier) and Static Sites.