Disruption affecting the provisioning of new instances in Singapore and partially in Oregon

Incident Report for Render

Update

Provisioning is recovering for free and paid services across all regions. Free services have resumed serving traffic. We are continuing to monitor for further issues.
Posted Apr 08, 2026 - 19:44 UTC

Update

Paid services are continuing to see recovery across builds and deploys. Free services remain disabled and will return errors if loaded in a browser.

Singapore and part of Oregon remain impacted.
Posted Apr 08, 2026 - 18:48 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 08, 2026 - 18:08 UTC

Update

We are disabling new free services in Singapore and partially in Oregon.
Posted Apr 08, 2026 - 16:05 UTC

Monitoring

We're seeing recovery across all regions.
Posted Apr 08, 2026 - 15:02 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 08, 2026 - 15:02 UTC

Update

We are now seeing the same issue affecting services in Oregon partially. We are investigating to remediate this as quickly as possible.
Posted Apr 08, 2026 - 14:42 UTC

Identified

Services with paid compute should now be operating normally. Please note that free services in this region are still intermittently disabled.
Posted Apr 08, 2026 - 11:23 UTC

Update

We are continuing to investigate this issue.
Posted Apr 08, 2026 - 11:22 UTC

Update

We are seeing some recovery following our mitigation efforts, but we are still working to identify the root cause for a long-term resolution.
Posted Apr 08, 2026 - 10:54 UTC

Update

We have temporarily disabled free services in Singapore. We are continuing to investigate and work to mitigate the issue.
Posted Apr 08, 2026 - 10:31 UTC

Investigating

This issue may affect new instances during builds, scaling, and similar operations. You may experience build/deploy failures. We are still investigating.
Posted Apr 08, 2026 - 09:57 UTC
This incident affects: Oregon (Web Services, Cron Jobs, Background Workers, Builds and Deploys, Web Services - Free Tier) and Singapore (Web Services, Cron Jobs, Background Workers, Builds and Deploys, Web Services - Free Tier).