Some deploys may be slow or hanging

Incident Report for Render

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 19:25 UTC

Monitoring

Deploy times have decreased and failures have dropped to baseline levels. We are monitoring for other impacts or other issues.
Posted Feb 11, 2026 - 19:15 UTC

Identified

Deploy delays and failures continue to remain elevated. We are continuing to work on this issue.
Posted Feb 11, 2026 - 18:24 UTC

Monitoring

We have implemented a mitigation and are currently observing positive results. We are continuing to monitor deploy health across the platform.
Posted Feb 11, 2026 - 16:39 UTC

Investigating

We are currently investigating this issue.
Posted Feb 11, 2026 - 16:16 UTC
This incident affected: Oregon (Builds and Deploys), Frankfurt (Builds and Deploys), Singapore (Builds and Deploys), Ohio (Builds and Deploys), and Virginia (Builds and Deploys).