Degraded builds/deploys (all regions)

Incident Report for Render

Resolved

Builds failure rates have recovered. Resolving.
Posted Jul 20, 2026 - 02:11 UTC

Monitoring

We are now seeing a recovery in our build failure rate. We are continuing to monitor the issue.
Posted Jul 20, 2026 - 01:54 UTC

Identified

GitHub continues to report an outage, https://www.githubstatus.com. This is causing authentication failures when trying to deploy from a GitHub repository.
Posted Jul 20, 2026 - 00:55 UTC

Investigating

We are currently investigating this issue.
Posted Jul 20, 2026 - 00:41 UTC
This incident affected: Oregon (Builds and Deploys), Frankfurt (Builds and Deploys), Singapore (Builds and Deploys), Ohio (Builds and Deploys), and Virginia (Builds and Deploys).