Duplicate logs in dashboard and Log Streams
Incident Report for Render
Resolved
Affected users won't see duplicate logs in log streams going forward.
Posted May 28, 2021 - 16:37 UTC
Update
We are still observing some log duplication, but based on our analysis we believe it is isolated to a small number of services that log infrequently (less than once per hour). We are continuing to work on a fix.
Posted May 26, 2021 - 17:31 UTC
Monitoring
We've rolled out our fix more broadly and are monitoring for log duplication.
Posted May 25, 2021 - 18:23 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 24, 2021 - 23:57 UTC
Update
We have identified the component in our logging infrastructure where the issue is occurring. We are in the process of rolling out a potential fix, and will monitor for a recurrence of the issue.
Posted May 24, 2021 - 23:57 UTC
Investigating
We are investigating reports of duplicated log lines in the dashboard log viewer and via Log Streams.
Posted May 24, 2021 - 20:35 UTC
This incident affected: Web Services, Cron Jobs, Background Workers, and Builds and Deploys.